What’s Vulnerable › Vulnerabilities
CVE-2026-114088: Trigger.dev before 4.5.4 Hardcoded Coordinator Secret Authentication Bypass via Socket.IO
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-27
- Weakness: CWE-798
Description
Trigger.dev before 4.5.4 contains a hardcoded default secret vulnerability in the /coordinator Socket.IO namespace that allows unauthenticated attackers to connect using the published coordinator-secret value. Attackers can emit READY_FOR_EXECUTION to retrieve decrypted run environment variables or send TASK_RUN_FAILED_TO_RUN and similar events to tamper with arbitrary runs.
Affected products
- Npm Trigger.Dev: before 4.5.4 — fixed in 4.5.4
- triggerdotdev trigger.dev: before 4.5.4 — fixed in 4.5.4
How to fix
Upgrade to a fixed version: Npm Trigger.Dev 4.5.4; triggerdotdev trigger.dev 4.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-gg6r-gp4c-89hp
- https://www.vulncheck.com/advisories/trigger-dev-before-4.5.4-hardcoded-coordinator-secret-authentication-bypass-via-socket-io
- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-gg6r-gp4c-89hp
Get alerted when CVE-2026-114088 or the next vulnerability affects your stack