What’s Vulnerable › Vulnerabilities
CVE-2026-114089: Trigger.dev before 4.5.2 CLI Auth-Code Phishing Leading to PAT Takeover
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-28
- Weakness: CWE-352
Description
Trigger.dev before 4.5.2 contains a cross-site request forgery vulnerability in the CLI authorization-code flow because loading /account/authorization-code/<code> mints a Personal Access Token without any consent step. Attackers mint an unauthenticated code, lure a logged-in user to that URL, then retrieve the victim's PAT from the unauthenticated /api/v1/token endpoint to take over the account.
Affected products
- triggerdotdev trigger.dev: before 4.5.2 — fixed in 4.5.2
How to fix
Upgrade to a fixed version: triggerdotdev trigger.dev 4.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-58mc-m3qq-6qrh
- https://www.vulncheck.com/advisories/trigger-dev-before-4.5.2-cli-auth-code-phishing-leading-to-pat-takeover
- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-58mc-m3qq-6qrh
Get alerted when CVE-2026-114089 or the next vulnerability affects your stack