What’s Vulnerable › Vulnerabilities
CVE-2026-114093: Trigger.dev before 4.5.6 Cross-Site Request Forgery via /logout Endpoint
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-27
- Weakness: CWE-352
Description
Trigger.dev before 4.5.6 contains a cross-site request forgery vulnerability that allows remote attackers to log out authenticated users by sending a link to the GET-based /logout endpoint. Attackers can lure victims into clicking an obfuscated, URL-encoded link that terminates their session, causing loss of unsaved work.
Affected products
- triggerdotdev trigger.dev: before 4.5.6 — fixed in 4.5.6
How to fix
Upgrade to a fixed version: triggerdotdev trigger.dev 4.5.6. Check the vendor advisory for mitigations.
References
- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-2cqj-rq4j-8835
- https://www.vulncheck.com/advisories/trigger-dev-before-4.5.6-cross-site-request-forgery-via-logout-endpoint
- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-2cqj-rq4j-8835
Get alerted when CVE-2026-114093 or the next vulnerability affects your stack