What’s Vulnerable › Vulnerabilities
CVE-2026-114098: Dulwich 0.22.5 before 1.2.8 Path Traversal via Stash Pop Symlinks
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-27
- Weakness: CWE-22
Description
Dulwich from 0.22.5 before 1.2.8 contains a path traversal vulnerability in stash.py pop() that allows attackers to write arbitrary files outside the worktree through intermediate directory symlinks. Attackers can craft a malicious repository whose popped stash writes a payload into .git/hooks/post-checkout, achieving code execution on the next checkout.
Affected products
- Pypi Dulwich: from 0.22.5 before 1.2.8; 0.22.5, 0.22.6, 0.22.7, 0.22.8, 0.23.0, 0.23.1 (+25) — fixed in 1.2.8
- jelmer dulwich: from 0.22.5 before 1.2.8 — fixed in 1.2.8
How to fix
Upgrade to a fixed version: Pypi Dulwich 1.2.8; jelmer dulwich 1.2.8. Check the vendor advisory for mitigations.
References
- https://github.com/jelmer/dulwich/security/advisories/GHSA-cm62-gvxx-vmxx
- https://www.vulncheck.com/advisories/dulwich-0.22.5-before-1.2.8-path-traversal-via-stash-pop-symlinks
Get alerted when CVE-2026-114098 or the next vulnerability affects your stack