What’s Vulnerable › Vulnerabilities
CVE-2026-114102: adm-zip before 0.6.1 Denial of Service via inflateAsync Unhandled Error Event
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-22
- Weakness: CWE-248
Description
adm-zip before 0.6.1 contains a denial of service vulnerability that allows unauthenticated attackers to crash the Node.js process via a malformed ZIP file, because inflateAsync in methods/inflater.js lacks a zlib stream error listener. Attackers can supply a ZIP with corrupted DEFLATE data processed by readFileAsync, readAsTextAsync, extractAllToAsync, or getDataAsync, triggering an uncatchable exception that terminates all in-flight requests.
Affected products
- cthackers adm-zip: before 0.6.1 — fixed in 0.6.1
How to fix
Upgrade to a fixed version: cthackers adm-zip 0.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/cthackers/adm-zip/security/advisories/GHSA-8238-w5pm-2374
- https://www.vulncheck.com/advisories/adm-zip-before-0.6.1-denial-of-service-via-inflateasync-unhandled-error-event
- https://github.com/cthackers/adm-zip/security/advisories/GHSA-8238-w5pm-2374
Get alerted when CVE-2026-114102 or the next vulnerability affects your stack