What’s Vulnerable › Vulnerabilities
CVE-2026-114107: HKUDS Vibe-Trading 0.1.0 before 0.1.7 Indirect Prompt Injection RCE via BashTool and BackgroundRunTool
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-22
- Weakness: CWE-1427
Description
HKUDS Vibe-Trading from 0.1.0 before 0.1.7 contains an indirect prompt injection vulnerability that allows remote attackers to execute shell commands as root by planting instructions in documents or web pages the agent processes. BashTool and BackgroundRunTool pass model-emitted commands to subprocess.run with shell=True and no allow-list or approval step, and read_url fetches arbitrary URLs, enabling command execution and server-side request forgery.
Affected products
- Pypi Vibe-Trading-Ai: from 0.1.0 before 0.1.7; 0.1.0, 0.1.1, 0.1.2, 0.1.3, 0.1.4, 0.1.5 (+1) — fixed in 0.1.7
- HKUDS Vibe-Trading: from 0.1.0 before 0.1.7 — fixed in 0.1.7
How to fix
Upgrade to a fixed version: Pypi Vibe-Trading-Ai 0.1.7; HKUDS Vibe-Trading 0.1.7. Check the vendor advisory for mitigations.
References
- https://github.com/HKUDS/Vibe-Trading/security/advisories/GHSA-jqmf-mx4f-hfr6
- https://www.vulncheck.com/advisories/hkuds-vibe-trading-0.1.0-before-0.1.7-indirect-prompt-injection-rce-via-bashtool-and-backgroundruntool
Get alerted when CVE-2026-114107 or the next vulnerability affects your stack