What’s Vulnerable › Vulnerabilities
CVE-2026-114111: Sharp before 0.35.5 RCE via librsvg Dependency Memory Vulnerability
- Severity: high (CVSS 8.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-28
- Weakness: CWE-416
Description
sharp before 0.35.5 bundles a librsvg dependency affected by a memory-related vulnerability (CVE-2026-96889) that, under certain runtime-specific conditions, can lead to code execution on glibc-based Linux. An attacker can supply a crafted SVG image that, when decoded by sharp through librsvg, may result in arbitrary code execution.
Affected products
- Npm Sharp: before 0.35.5 — fixed in 0.35.5
- lovell sharp: before 0.35.5 — fixed in 0.35.5
How to fix
Upgrade to a fixed version: Npm Sharp 0.35.5; lovell sharp 0.35.5. Check the vendor advisory for mitigations.
References
- https://github.com/lovell/sharp/security/advisories/GHSA-wq5f-xc86-pv6w
- https://www.vulncheck.com/advisories/sharp-before-0.35.5-rce-via-librsvg-dependency-memory-vulnerability
Get alerted when CVE-2026-114111 or the next vulnerability affects your stack