What’s Vulnerable › Vulnerabilities
CVE-2026-114112: Sharp before 0.35.4 RCE via bundled libheif AVIF decoding
- Severity: high (CVSS 8.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-22
- Weakness: CWE-122
Description
Sharp before 0.35.4 bundles a vulnerable libheif dependency that allows attackers to achieve possible remote code execution on glibc-based Linux by supplying crafted images. Attackers can submit malicious AVIF/HEIF input to applications processing untrusted images with sharp, triggering libheif decoding flaws to execute code.
Affected products
- lovell sharp: before 0.35.4 — fixed in 0.35.4
How to fix
Upgrade to a fixed version: lovell sharp 0.35.4. Check the vendor advisory for mitigations.
References
- https://github.com/lovell/sharp/security/advisories/GHSA-rgj7-g3m4-5g8c
- https://www.vulncheck.com/advisories/sharp-before-0.35.4-rce-via-bundled-libheif-avif-decoding
Get alerted when CVE-2026-114112 or the next vulnerability affects your stack