What’s Vulnerable › Vulnerabilities
CVE-2026-114120: SchedulePress before 5.3.5 Missing Authorization via wpsp_el_editor_form AJAX Action
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-22
- Weakness: CWE-862
Description
SchedulePress before 5.3.5 contains a missing authorization vulnerability that allows authenticated Contributor-level users to change any post's status and publish date via the wpsp_el_editor_form AJAX action. Attackers can reuse the wpsp-el-editor nonce from the Elementor modal to unpublish or reschedule administrator posts, or publish other users' pending or draft posts.
Affected products
- WPDeveloper SchedulePress: before 5.3.5 — fixed in 5.3.5
How to fix
Upgrade to a fixed version: WPDeveloper SchedulePress 5.3.5. Check the vendor advisory for mitigations.
References
- https://github.com/WPDevelopers/wp-scheduled-posts/blob/v5.3.4/includes/Admin.php#L1276-L1521
- https://github.com/WPDevelopers/wp-scheduled-posts/commit/0e7af0fcbf0851687c34db2997117032978dbe06
- https://wordpress.org/plugins/wp-scheduled-posts/
- https://www.vulncheck.com/advisories/schedulepress-before-5.3.5-missing-authorization-via-wpsp-el-editor-form-ajax-action
Get alerted when CVE-2026-114120 or the next vulnerability affects your stack