What’s Vulnerable › Vulnerabilities
CVE-2026-114386: Pydantic AI Harness before 0.59.0 CodeMode Tool Call Limit Bypass via run_code
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-22
- Weakness: CWE-770
Description
Pydantic AI Harness before 0.59.0 fails to enforce UsageLimits.tool_calls_limit on nested tool calls dispatched from run_code in the CodeMode toolset. Users or prompt-injected content can make the sandboxed program invoke tools via run_nested_call() without check_before_tool_call, exceeding operator limits on costly or side-effecting tools.
Affected products
- pydantic-ai-harness: before 0.59.0 — fixed in 0.59.0
How to fix
Upgrade to a fixed version: pydantic-ai-harness 0.59.0. Check the vendor advisory for mitigations.
References
- https://github.com/pydantic/pydantic-ai/blob/v2.58.0/src/pydantic_ai_harness/pydantic_ai_harness/code_mode/_toolset.py#L642-L680
- https://github.com/pydantic/pydantic-ai/commit/eb27b2b89fe76ae23ee9b6fc9eb4b227a4967949
- https://github.com/pydantic/pydantic-ai/pull/10362
- https://github.com/pydantic/pydantic-ai/releases/tag/v2.59.0
- https://pypi.org/project/pydantic-ai-harness/0.59.0/
- https://www.vulncheck.com/advisories/pydantic-ai-harness-before-0.59.0-codemode-tool-call-limit-bypass-via-run-code
Get alerted when CVE-2026-114386 or the next vulnerability affects your stack