What’s Vulnerable › Vulnerabilities
CVE-2026-114387: Shopper 2.0.0 before 2.6.0 Privilege Escalation via Unguarded Livewire Components
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-27
- Weakness: CWE-862
Description
Shopper from 2.0.0 before 2.6.0 contains a missing authorization vulnerability that allows admin-panel users holding only access_dashboard to create administrators and grant permissions. Attackers can call CreateTeamMember::store() or Permissions::togglePermission() directly over /livewire/update to create admin accounts and escalate to full administrator.
Affected products
- shopperlabs shopper: from 2.0.0 before 2.6.0 — fixed in 2.6.0
How to fix
Upgrade to a fixed version: shopperlabs shopper 2.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/shopperlabs/shopper/blob/v2.5.0/packages/admin/src/Livewire/Components/Settings/Team/Permissions.php#L18-L49
- https://github.com/shopperlabs/shopper/blob/v2.5.0/packages/admin/src/Livewire/SlideOvers/CreateTeamMember.php#L102-L123
- https://github.com/shopperlabs/shopper/commit/d1ac6cee2f02e5a84262fbeb87c689bd38df672f
- https://github.com/shopperlabs/shopper/issues/433
- https://github.com/shopperlabs/shopper/releases/tag/v2.6.0
- https://www.vulncheck.com/advisories/shopper-2.0.0-before-2.6.0-privilege-escalation-via-unguarded-livewire-components
Get alerted when CVE-2026-114387 or the next vulnerability affects your stack