What’s Vulnerable › Vulnerabilities
CVE-2026-11440: theonedev REST API default-branch improper authorization
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-06 · updated 2026-07-23
- Weakness: CWE-266
Description
A vulnerability was determined in theonedev onedev up to 15.0.5. This affects an unknown part of the file /repositories/{projectId}/default-branch of the component REST API. This manipulation of the argument project.defaultBranch causes improper authorization. It is possible to initiate the attack remotely. Upgrading to version 15.0.6 is able to mitigate this issue. Upgrading the affected component is advised.
Affected products
- theonedev onedev: 15.0.0, 15.0.1, 15.0.2, 15.0.3, 15.0.4, 15.0.5
References
- https://github.com/theonedev/onedev/releases/tag/v15.0.6
- https://vuldb.com/cve/CVE-2026-11440
- https://vuldb.com/submit/822956
- https://vuldb.com/vuln/369020
- https://vuldb.com/vuln/369020/cti
- https://www.cnblogs.com/aibot/p/19994142
Get alerted when CVE-2026-11440 or the next vulnerability affects your stack