What’s Vulnerable › Vulnerabilities

CVE-2026-114429: WP VR 8.5.49 - 9.0.2 - Contributor+ Stored XSS via Hotspot Content

Description

The WPVR WordPress plugin before 9.0.3 does not properly sanitise and escape some of its tour hotspot content before storing it and outputting it on the front end, which could allow users with the Contributor role and above to perform Stored Cross-Site Scripting attacks that execute in the browser of any user viewing the affected tour.

Affected products

How to fix

Upgrade to a fixed version: WPVR 9.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-114429 or the next vulnerability affects your stack