What’s Vulnerable › Vulnerabilities
CVE-2026-114660: Grav 2.0.0 before 2.2.5 Unauthorized Page Deletion via Flex Form Directives
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-22
- Weakness: CWE-470
Description
Grav from 2.0.0 before 2.2.5 contains an improper access control vulnerability in FlexDirectory::dynamicFlexField() that allows page authors to call arbitrary Flex object methods via flex-*@ directives in page frontmatter. When a user with page edit rights opens the page, directives calling setStorageKey() and delete() run in their session, deleting protected pages neither account may delete.
Affected products
- getgrav grav: from 2.0.0 before 2.2.5 — fixed in 2.2.5
How to fix
Upgrade to a fixed version: getgrav grav 2.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-95jr-q4xh-27vr
- https://www.vulncheck.com/advisories/grav-2.0.0-before-2.2.5-unauthorized-page-deletion-via-flex-form-directives
Get alerted when CVE-2026-114660 or the next vulnerability affects your stack