What’s Vulnerable › Vulnerabilities
CVE-2026-114661: OpenRemote 1.2.0 before 1.31.0 Missing Authorization in Gateway Tunnel Endpoints
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-28
- Weakness: CWE-862
Description
OpenRemote 1.2.0 before 1.31.0 contains a missing authorization vulnerability in GatewayServiceResource that allows any authenticated user to start, stop and query gateway tunnels without an administrative role. Attackers can send POST or DELETE requests to the gateway tunnel endpoint to open persistent bidirectional TCP circuits into an edge gateway's network or tear down operator tunnels.
Affected products
- openremote: from 1.2.0 before 1.31.0 — fixed in 1.31.0
How to fix
Upgrade to a fixed version: openremote 1.31.0. Check the vendor advisory for mitigations.
References
- https://github.com/openremote/core/security/advisories/GHSA-5h8w-vg25-fw38
- https://www.vulncheck.com/advisories/openremote-1.2.0-before-1.31.0-missing-authorization-in-gateway-tunnel-endpoints
- https://github.com/openremote/core/security/advisories/GHSA-5h8w-vg25-fw38
Get alerted when CVE-2026-114661 or the next vulnerability affects your stack