What’s Vulnerable › Vulnerabilities
CVE-2026-114715
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-30
- Weakness: CWE-863
Description
Roundcube Webmail before 1.6.20 and 1.7.x before 1.7.5 is affected by an incorrect authorization vulnerability in the Modoboa driver of the password plugin. The driver took the first entry of the account search result returned by the Modoboa API instead of matching the authenticated user, so a password change could be applied to a different account. Upstream fixed this in the commit “Fix bug where Password Modoboa driver could change password for another account”, which selects the account whose username matches and fails if none does.
Affected products
- Roundcube Webmail: from 1.6.0 before 1.6.20; from 1.7.0 before 1.7.5 — fixed in 1.6.20, 1.7.5
- Roundcube Webmail: from 1.6.0 before 1.6.20; from 1.7.0 before 1.7.5 — fixed in 1.6.20, 1.7.5
How to fix
Upgrade to a fixed version: Roundcube Webmail 1.6.20, 1.7.5; Roundcube Webmail 1.6.20, 1.7.5. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/1151279
- https://github.com/roundcube/roundcubemail/commit/3d9d05bfe2da7f93b8d47e68cadab22bb67e6cc9
- https://github.com/roundcube/roundcubemail/commit/e6a77272a5837e7104238a2f270ac412ff0a8ff3
- https://github.com/roundcube/roundcubemail/releases/tag/1.6.20
- https://github.com/roundcube/roundcubemail/releases/tag/1.7.5
- https://roundcube.net/news/2026/10/19/security-updates-1.6.20-and-1.7.5
Get alerted when CVE-2026-114715 or the next vulnerability affects your stack