What’s Vulnerable › Vulnerabilities

CVE-2026-114718

Description

Roundcube Webmail before 1.6.20 and 1.7.x before 1.7.5 is affected by a cross-site scripting vulnerability in the password plugin. Error text returned by a password driver was concatenated into the message presented to the user without HTML escaping, so a backend able to influence that text, such as the DirectAdmin API, could inject script into the Roundcube interface. Upstream fixed this in the commit “Fix XSS issue in handling of password driver error responses”, which escapes the driver message before display.

Affected products

How to fix

Upgrade to a fixed version: Roundcube Webmail 1.6.20, 1.7.5; Roundcube Webmail 1.6.20, 1.7.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-114718 or the next vulnerability affects your stack