What’s Vulnerable › Vulnerabilities
CVE-2026-114743: InstaWP Connect < 0.1.4.2 - Authenticated Plugin Settings Update via instawp_update_settings
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-26
- Weakness: CWE-862
Description
The InstaWP Connect WordPress plugin before 0.1.4.2 does not perform a capability check on its InstaWP Connect WordPress plugin before 0.1.4.2-settings update action, verifying only a nonce, allowing an authenticated user holding a low-privileged role that an administrator has granted access to the InstaWP Connect WordPress plugin before 0.1.4.2's sync feature to overwrite the InstaWP Connect WordPress plugin before 0.1.4.2's settings, including the setting controlling which roles may access that feature. The role grant is not enabled by default.
Affected products
- InstaWP Connect: before 0.1.4.2 — fixed in 0.1.4.2
How to fix
Upgrade to a fixed version: InstaWP Connect 0.1.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-114743 or the next vulnerability affects your stack