What’s Vulnerable › Vulnerabilities

CVE-2026-115214: Datawiza Proxy Auth Plugin 1.1.0 - Unauthenticated Privilege Escalation via X-User and Role Headers

Description

The Datawiza Proxy Auth Plugin WordPress plugin before 1.1.1 does not verify that the user-identity and role HTTP request headers it trusts originate from a trusted reverse proxy, allowing unauthenticated attackers to create and authenticate as a WordPress administrator.

Summary

The Datawiza Proxy Auth Plugin for WordPress before 1.1.1 trusts user-identity and role HTTP headers without verifying they come from a trusted reverse proxy. This lets unauthenticated attackers send crafted X-User and role headers to create and log in as a WordPress administrator, a critical (CVSS 9.8) privilege escalation. The flaw is not in CISA KEV and EPSS estimates a 0.1% chance of exploitation in 30 days. Update the plugin to 1.1.1 or later; if you cannot patch immediately, restrict access so only your trusted proxy can reach the site and strip these headers from external requests.

تثق إضافة Datawiza Proxy Auth Plugin لـ WordPress بإصدارات ما قبل 1.1.1 بترويسات HTTP الخاصة بهوية المستخدم والدور دون التحقق من أنها صادرة عن وكيل عكسي موثوق. يتيح ذلك لمهاجمين غير مصادق عليهم إرسال ترويسات X-User وترويسات الدور المزيفة لإنشاء حساب مسؤول WordPress وتسجيل الدخول به، وهي تصعيد صلاحيات خطير بتقييم CVSS 9.8. لا توجد الثغرة في قائمة CISA KEV، وتقدّر EPSS احتمال الاستغلال خلال 30 يوماً بنسبة 0.1%. حدّثوا الإضافة إلى الإصدار 1.1.1 أو أحدث، وإن تعذر ذلك فاقصروا الوصول على الوكيل الموثوق وأزيلوا هذه الترويسات من الطلبات الخارجية.

Affected products

How to fix

Upgrade to a fixed version: Datawiza Proxy Auth Plugin 1.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-115214 or the next vulnerability affects your stack