What’s Vulnerable › Vulnerabilities
CVE-2026-115350: Mistune before 3.3.0 Stored XSS via Include Directive HTML Files
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-29
- Weakness: CWE-79
Description
Mistune before 3.3.0 contains a cross-site scripting vulnerability in the Include directive that emits included .html, .xhtml, or .htm file content as raw block_html tokens. Attackers who can plant an HTML file readable by the renderer can reference it via an include directive, combined with path traversal, to execute stored scripts when escape=False is set.
Affected products
- lepture mistune: before 3.3.0 — fixed in 3.3.0
How to fix
Upgrade to a fixed version: lepture mistune 3.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/lepture/mistune/security/advisories/GHSA-96vr-jm8v-g22j
- https://www.vulncheck.com/advisories/mistune-before-3.3.0-stored-xss-via-include-directive-html-files
Get alerted when CVE-2026-115350 or the next vulnerability affects your stack