What’s Vulnerable › Vulnerabilities
CVE-2026-115353: Mistune before 3.3.0 Path Traversal via include Directive
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-22
- Weakness: CWE-22
Description
Mistune before 3.3.0 contains a path traversal vulnerability in the RST include directive that allows attackers to read arbitrary files by supplying relative or absolute paths. Attackers can submit markdown containing include directives referencing ../ sequences or absolute paths to embed sensitive files like credentials or environment data in rendered HTML.
Affected products
- lepture mistune: before 3.3.0 — fixed in 3.3.0
How to fix
Upgrade to a fixed version: lepture mistune 3.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/lepture/mistune/security/advisories/GHSA-9jjx-3hq3-hx4j
- https://www.vulncheck.com/advisories/mistune-before-3.3.0-path-traversal-via-include-directive
Get alerted when CVE-2026-115353 or the next vulnerability affects your stack