What’s Vulnerable › Vulnerabilities
CVE-2026-115355: Mistune before 3.3.0 Path Traversal and XSS via Include Directive
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-29
- Weakness: CWE-22
Description
Mistune before 3.3.0 contains a path traversal vulnerability in the Include directive that allows attackers to read arbitrary files by supplying ../ sequences in include paths. Attackers can also inject HTML through unescaped error messages and included file contents to perform cross-site scripting even when escape=True is set.
Affected products
- lepture mistune: before 3.3.0 — fixed in 3.3.0
How to fix
Upgrade to a fixed version: lepture mistune 3.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/lepture/mistune/security/advisories/GHSA-h7ww-273w-6cm8
- https://www.vulncheck.com/advisories/mistune-before-3.3.0-path-traversal-and-xss-via-include-directive
Get alerted when CVE-2026-115355 or the next vulnerability affects your stack