What’s Vulnerable › Vulnerabilities
CVE-2026-115358: OpenBao before 2.6.3 Sensitive Data Leak in Audit Log via Malformed Parameters
- Severity: low (CVSS 2.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-29
- Weakness: CWE-532
Description
OpenBao before 2.6.3 contains an information disclosure vulnerability that allows attackers to leak sensitive data into audit logs by sending malformed plugin parameters. Attackers can submit requests with malformed TypeKVPair or TypeHeader field values, causing error messages containing sensitive input to be recorded in audit logs.
Affected products
- openbao: before 2.6.3 — fixed in 2.6.3
How to fix
Upgrade to a fixed version: openbao 2.6.3. Check the vendor advisory for mitigations.
References
- https://github.com/openbao/openbao/security/advisories/GHSA-8xxq-mq9m-xmhw
- https://www.vulncheck.com/advisories/openbao-before-2.6.3-sensitive-data-leak-in-audit-log-via-malformed-parameters
Get alerted when CVE-2026-115358 or the next vulnerability affects your stack