What’s Vulnerable › Vulnerabilities
CVE-2026-115359: OpenBao before 2.6.4 and 2.7.0 before 2.7.1 Role-Based Rate Limit Quota Bypass via Request Parsing
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-29
- Weakness: CWE-799
Description
OpenBao before 2.6.4 and 2.7.x before 2.7.1 contains a flaw in its rate limit quota subsystem where role resolution fails for requests with form-encoded bodies or forwarded certificates, so quota rules scoped to backend-specific roles are not enforced. Valid callers can repeatedly issue tokens without consuming the configured role-based rate limit budget.
Affected products
- openbao: before 2.6.4; from 2.7.0 before 2.7.1 — fixed in 2.6.4, 2.7.1
How to fix
Upgrade to a fixed version: openbao 2.6.4, 2.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/openbao/openbao/security/advisories/GHSA-5v22-543h-wg96
- https://www.vulncheck.com/advisories/openbao-before-2.6.4-and-2.7.0-before-2.7.1-role-based-rate-limit-quota-bypass-via-request-parsing
Get alerted when CVE-2026-115359 or the next vulnerability affects your stack