What’s Vulnerable › Vulnerabilities
CVE-2026-115365: OpenBao 2.3.0 before 2.6.3 Incorrect Authorization via Policy Cache Namespace Traversal
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-23
- Weakness: CWE-863
Description
OpenBao from 2.3.0 before 2.6.3 contains an incorrect authorization vulnerability in its ACL policy cache that allows tokens to reference policies from arbitrary namespaces using specially crafted policy names. Attackers holding such tokens can gain capabilities of cached policies in other namespaces, including the root namespace, to act across namespace boundaries.
Affected products
- openbao: from 2.3.0 before 2.6.3 — fixed in 2.6.3
How to fix
Upgrade to a fixed version: openbao 2.6.3. Check the vendor advisory for mitigations.
References
- https://github.com/openbao/openbao/security/advisories/GHSA-mjch-vcw3-hhmf
- https://www.vulncheck.com/advisories/openbao-2.3.0-before-2.6.3-incorrect-authorization-via-policy-cache-namespace-traversal
Get alerted when CVE-2026-115365 or the next vulnerability affects your stack