What’s Vulnerable › Vulnerabilities
CVE-2026-115366: OpenBao 2.3.0 before 2.6.3 Missing Root Namespace Enforcement in Plugin Catalog APIs
- Severity: low (CVSS 2.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-26
- Weakness: CWE-863
Description
OpenBao from 2.3.0 before 2.6.3 contains an improper authorization vulnerability that allows privileged child-namespace tokens to modify plugin registrations because /v1/sys/plugins/catalog/* is not restricted to the root namespace. Attackers can remove existing registrations, create invalid ones, or register installed plugins through a child namespace's sys/ mount, causing denial of service.
Affected products
- openbao: from 2.3.0 before 2.6.3 — fixed in 2.6.3
How to fix
Upgrade to a fixed version: openbao 2.6.3. Check the vendor advisory for mitigations.
References
- https://github.com/openbao/openbao/security/advisories/GHSA-cg72-x35g-xfp8
- https://www.vulncheck.com/advisories/openbao-2.3.0-before-2.6.3-missing-root-namespace-enforcement-in-plugin-catalog-apis
Get alerted when CVE-2026-115366 or the next vulnerability affects your stack