What’s Vulnerable › Vulnerabilities
CVE-2026-115369: OpenBao 2.5.0 before 2.6.2 PKI allowed_ip_sans_cidr Bypass via CSR IP SANs
- Severity: low (CVSS 2.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-29
- Weakness: CWE-863
Description
OpenBao from 2.5.0 before 2.6.2 fails to enforce the PKI role allowed_ip_sans_cidr restriction on IP SANs taken from a CSR when use_csr_sans is enabled. Authenticated callers with sign permission can submit a CSR with an out-of-range IP SAN to pki/sign/<role> and obtain CA-signed certificates for unauthorized IPs.
Affected products
- openbao: from 2.5.0 before 2.6.2 — fixed in 2.6.2
How to fix
Upgrade to a fixed version: openbao 2.6.2. Check the vendor advisory for mitigations.
References
- https://github.com/openbao/openbao/security/advisories/GHSA-g892-p242-8g86
- https://www.vulncheck.com/advisories/openbao-2.5.0-before-2.6.2-pki-allowed-ip-sans-cidr-bypass-via-csr-ip-sans
Get alerted when CVE-2026-115369 or the next vulnerability affects your stack