What’s Vulnerable › Vulnerabilities
CVE-2026-115387: Wasmtime before 36.0.16, 37.0.0 before 48.0.3, and 49.0.0 before 49.0.1 Host Panic via WASI Filesystem Timestamp Overflow
- Severity: medium (CVSS 6.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-22
- Weakness: CWE-190
Description
Wasmtime before 36.0.16, 37.0.0 before 48.0.3, and 49.0.0 before 49.0.1 contains a denial of service vulnerability in wasmtime-wasi that allows guest WASI programs to panic the host via overflowing filesystem timestamps. Attackers can pass atim or mtim values whose sub-second field overflows the seconds field to path_filestat_set_times, fd_filestat_set_times, set-times, or set-times-at, crashing the host.
Affected products
- bytecodealliance wasmtime: before 36.0.16; from 37.0.0 before 48.0.3; from 49.0.0 before 49.0.1 — fixed in 36.0.16, 48.0.3, 49.0.1
How to fix
Upgrade to a fixed version: bytecodealliance wasmtime 36.0.16, 48.0.3, 49.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/bytecodealliance/wasmtime/security/advisories/GHSA-j2g9-4prp-pf6h
- https://www.vulncheck.com/advisories/wasmtime-before-36.0.16-37.0.0-before-48.0.3-and-49.0.0-before-49.0.1-host-panic-via-wasi-filesystem-timestamp-overflow
Get alerted when CVE-2026-115387 or the next vulnerability affects your stack