What’s Vulnerable › Vulnerabilities
CVE-2026-115505: libsmb2 before 6.3 Integer Overflow in DCE/RPC NDR Decoder via NetrShareEnum
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-29
- Weakness: CWE-190
Description
libsmb2 before 6.3 contains integer overflow vulnerabilities in the DCE/RPC NDR decoder in lib/dcerpc.c that allow heap out-of-bounds reads and writes. A malicious SMB server or machine-in-the-middle on unsigned connections can send crafted NetrShareEnum replies with wrapping actual_count or max_count values when clients call smb2_share_enum_async(), corrupting heap memory.
Affected products
- sahlberg libsmb2: before 6.3 — fixed in 6.3
How to fix
Upgrade to a fixed version: sahlberg libsmb2 6.3. Check the vendor advisory for mitigations.
References
- https://github.com/sahlberg/libsmb2
- https://github.com/sahlberg/libsmb2/commit/a79f6914cb5ed3f74293d15cdea901261ce179ff
- https://github.com/sahlberg/libsmb2/issues/496
- https://github.com/sahlberg/libsmb2/releases/tag/libsmb2-6.3
- https://hackmd.io/@haindpwn/libsmb2-dcerpc-ndr-count-overflow-oob
- https://www.vulncheck.com/advisories/libsmb2-before-6.3-integer-overflow-in-dce-rpc-ndr-decoder-via-netrshareenum
Get alerted when CVE-2026-115505 or the next vulnerability affects your stack