What’s Vulnerable › Vulnerabilities
CVE-2026-115717: Frappe Builder before 1.36.1 SSRF via convert_to_webp
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-26 · updated 2026-10-26
- Weakness: CWE-918
Description
Frappe Builder versions before 1.36.1 contain a server-side request forgery vulnerability in the convert_to_webp API endpoint, which lacks the has_page_write access control applied to similar asset-ingest handlers and performs an unprotected requests.get call that follows redirects without re-validating resolved IP addresses. A low-privilege authenticated user can supply an image_url pointing to an internal address or use DNS rebinding and open redirects to make the server fetch internal network resources or cloud metadata endpoints, with successful image responses saved to a world-readable /files/ URL enabling data exfiltration or blind probing of internal hosts.
Affected products
- frappe builder: from 1.0.0 before 1.36.1 — fixed in 1.36.1
How to fix
Upgrade to a fixed version: frappe builder 1.36.1. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/builder/releases/tag/v1.36.1
- https://github.com/frappe/builder/security/advisories/GHSA-5qcg-q3jf-fjcg
- https://www.vulncheck.com/advisories/frappe-builder-before-ssrf-via-convert-to-webp
Get alerted when CVE-2026-115717 or the next vulnerability affects your stack