What’s Vulnerable › Vulnerabilities
CVE-2026-115718: Frappe Builder 1.33.0 before 1.36.0 Missing Authorization via improve_prompt
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-26 · updated 2026-10-26
- Weakness: CWE-862
Description
Frappe Builder versions 1.33.0 before1.36.0 contain a missing authorization vulnerability in the improve_prompt endpoint that allows any authenticated non-Guest session to invoke LLM completions without proper permission checks. Attackers can call the improve_prompt API to leverage the site owner's stored OpenRouter API key via resolve_api_key, consuming paid LLM credits and effectively turning the site into a free LLM proxy.
Affected products
- frappe builder: from 1.33.0 before 1.36.0 — fixed in 1.36.0
How to fix
Upgrade to a fixed version: frappe builder 1.36.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/builder/releases/tag/v1.36.0
- https://github.com/frappe/builder/security/advisories/GHSA-58mj-c563-p78w
- https://www.vulncheck.com/advisories/frappe-builder-before-missing-authorization-via-improve-prompt
Get alerted when CVE-2026-115718 or the next vulnerability affects your stack