What’s Vulnerable › Vulnerabilities

CVE-2026-11572

Description

Versions of the package degit before 2.8.6, from 3.0.0 and before 3.3.1 are vulnerable to Command Injection due to improper sanitisation of user input for git shell commands directly invoked with exec() method by _cloneWithGit() and fetchRefs() functions. An attacker can execute arbitrary operating system commands as the process user by supplying a specially crafted git repository name.

Affected products

How to fix

Upgrade to a fixed version: degit 2.8.6, 3.3.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-11572 or the next vulnerability affects your stack