What’s Vulnerable › Vulnerabilities
CVE-2026-115749: hydra-ray-launcher 1.1.0.dev1 before 1.2.2 and 1.4.0.dev4 before 1.4.0rc2 Arbitrary Module Import
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-23 · updated 2026-10-23
- Weakness: CWE-470
Description
hydra-ray-launcher 1.1.0.dev1 before 1.2.2 and 1.4.0.dev4 before 1.4.0rc2 contains an arbitrary module import vulnerability via the ray_pkg_version OmegaConf resolver passing input to importlib.import_module(). Attackers controlling configuration values or command-line overrides can supply a ray_pkg_version interpolation to import any installed module, triggering its import-time side effects in the application process.
Affected products
- hydra-ecosystem hydra-ray-launcher: from 1.1.0.dev1 before 1.2.2; from 1.4.0.dev4 before 1.4.0rc2 — fixed in 1.2.2, 1.4.0rc2
How to fix
Upgrade to a fixed version: hydra-ecosystem hydra-ray-launcher 1.2.2, 1.4.0rc2. Check the vendor advisory for mitigations.
References
- https://github.com/hydra-ecosystem/hydra/commit/46e2fdaecd54dbfc041616b1229bd1614b73d765
- https://github.com/hydra-ecosystem/hydra/pull/3566
- https://github.com/hydra-ecosystem/hydra/security/advisories/GHSA-h34c-q33w-3r7q
- https://pypi.org/project/hydra-ray-launcher/1.2.2/
- https://www.vulncheck.com/advisories/hydra-ray-launcher-1.1.0-dev1-before-1.2.2-and-1.4.0-dev4-before-1.4-0rc2-arbitrary-module-import
Get alerted when CVE-2026-115749 or the next vulnerability affects your stack