What’s Vulnerable › Vulnerabilities
CVE-2026-115750: mcp-from-openapi from 2.5.0 before 2.9.0 Credential Leak via Cross-Origin Redirects
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-23 · updated 2026-10-23
- Weakness: CWE-522
Description
mcp-from-openapi from 2.5.0 before 2.9.0 contains a credential exposure vulnerability that allows attackers to capture Authorization and Cookie headers because safeFetch() forwards them on cross-origin redirects. Attackers controlling a spec host or abusing an open redirect can redirect fromURL() spec requests to their own origin to steal bearer tokens or cookies.
Affected products
- agentfront mcp-from-openapi: from 2.5.0 before 2.9.0 — fixed in 2.9.0
How to fix
Upgrade to a fixed version: agentfront mcp-from-openapi 2.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/agentfront/mcp-from-openapi/commit/47fb7a655de33958b0c923490ab244343eb5fc44
- https://github.com/agentfront/mcp-from-openapi/pull/42
- https://github.com/agentfront/mcp-from-openapi/releases/tag/v2.9.0
- https://github.com/agentfront/mcp-from-openapi/security/advisories/GHSA-ff5q-5r4v-fw4v
- https://www.vulncheck.com/advisories/mcp-from-openapi-from-2.5.0-before-2.9.0-credential-leak-via-cross-origin-redirects
Get alerted when CVE-2026-115750 or the next vulnerability affects your stack