What’s Vulnerable › Vulnerabilities
CVE-2026-115914: vLLM DeepSeek-OCR image processing vulnerable to denial of service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-26 · updated 2026-10-30
- Weakness: CWE-617
Description
vLLM is an inference and serving engine for large language models. From 0.11.1 until 0.32.0, the DeepSeek-OCR, DeepSeek-OCR-2, and Unlimited-OCR image path allows a remote client that can reach the OpenAI-compatible API to submit a legal image whose normalized pixels sum to zero when that image is alone in its per-step encoder batch. _parse_and_validate_image_input returns no embedding, embed_multimodal propagates that value, and sanity_check_mm_encoder_outputs triggers a fatal assertion that shuts down the engine for all users. This issue is fixed in version 0.32.0.
Affected products
- vllm-project vllm: from 0.11.1 before 0.32.0 — fixed in 0.32.0
- vllm-project vllm: from 0.11.1, < 0.32.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.32.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/commit/c15672cfb49152ebf65cfd188e71b84593ec5686
- https://github.com/vllm-project/vllm/pull/59417
- https://github.com/vllm-project/vllm/releases/tag/v0.32.0
- https://github.com/vllm-project/vllm/security/advisories/GHSA-gq5q-89c7-vhvx
Get alerted when CVE-2026-115914 or the next vulnerability affects your stack