What’s Vulnerable › Vulnerabilities

CVE-2026-115915: vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE

Description

vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.

Summary

vLLM before 0.32.0 passes attacker-controlled image bytes to Pillow without restricting decoder selection, so an EPS payload can reach host components. On hosts with a Ghostscript affected by CVE-2024-29510 this can mean command execution with the vLLM process's privileges; with Pillow 12.0.0 through 12.2.0 it can trigger CVE-2026-59203 and exhaust media-loading workers, causing denial of service. CVSS is 9.8 critical, but there is no evidence of exploitation (not in CISA KEV, SSVC none, EPSS 0.6%). Upgrade vLLM to 0.32.0; deployments without the vulnerable Ghostscript or Pillow versions are not exposed to the corresponding impact.

يمرر vLLM قبل الإصدار 0.32.0 بايتات صور يتحكم بها المهاجم إلى Pillow دون تقييد اختيار وحدة فك الترميز، ما يسمح لحمولة EPS بالوصول إلى مكونات المضيف. على المضيفين الذين يعانون من Ghostscript متأثر بـ CVE-2024-29510 قد يعني ذلك تنفيذ أوامر بصلاحيات عملية vLLM، ومع Pillow من 12.0.0 إلى 12.2.0 قد يُستثار CVE-2026-59203 وتُستنزف عمال تحميل الوسائط ما يؤدي إلى حجب الخدمة. درجة CVSS هي 9.8 حرجة، لكن لا دليل على استغلال فعلي (ليس في CISA KEV، وتقييم SSVC هو none، واحتمال EPSS 0.6%). رقّوا vLLM إلى 0.32.0؛ والبيئات الخالية من إصدارات Ghostscript أو Pillow المتأثرة غير معرّضة للأثر المقابل.

Affected products

How to fix

Upgrade to a fixed version: vllm-project vllm 0.32.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-115915 or the next vulnerability affects your stack