What’s Vulnerable › Vulnerabilities
CVE-2026-115917: vLLM: Permissive default CORS origins allow cross-origin requests to the vLLM HTTP server
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-26 · updated 2026-10-31
- Weakness: CWE-942
Description
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, the OpenAI-compatible server configures Starlette CORSMiddleware with allowed_origins set to a wildcard by default. A malicious web page can use a victim's browser to reach an unauthenticated vLLM server on localhost, an internal network, or a VPN, call endpoints including GET /v1/models and POST /v1/chat/completions, consume GPU resources, and read responses. Cookie-based cross-site request forgery does not apply because credentials are disabled by default, and deployments requiring bearer authentication are exposed only when the caller already has a usable token. This issue is fixed in version 0.32.0.
Affected products
- vllm-project vllm: before 0.32.0 — fixed in 0.32.0
- vllm-project vllm: before 0.32.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.32.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/commit/fcae5c98870ff2c20659731dce7ba3a3ff0d48aa
- https://github.com/vllm-project/vllm/pull/61009
- https://github.com/vllm-project/vllm/releases/tag/v0.32.0
- https://github.com/vllm-project/vllm/security/advisories/GHSA-vvpg-rrww-wpmh
Get alerted when CVE-2026-115917 or the next vulnerability affects your stack