What’s Vulnerable › Vulnerabilities
CVE-2026-115918: vLLM: Responses API bypasses trust_request_chat_template for chat_template_kwargs
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-26 · updated 2026-10-30
- Weakness: CWE-400
Description
vLLM is an inference and serving engine for large language models. From 0.16.0 until 0.32.0, the /v1/responses endpoint allows an authenticated caller to place an attacker-controlled template in chat_template_kwargs[chat_template] when no server template is configured. ChatParams.get_apply_chat_template_kwargs() preserves that value without enforcing trust_request_chat_template, so the request can bypass the intended trust policy and cause CPU or memory exhaustion through Jinja rendering. This issue is fixed in version 0.32.0.
Affected products
- vllm-project vllm: from 0.16.0 before 0.32.0 — fixed in 0.32.0
- vllm-project vllm: from 0.16.0, < 0.32.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.32.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/commit/cff08b461e086523cee8bba5bd3c66d302625134
- https://github.com/vllm-project/vllm/pull/50300
- https://github.com/vllm-project/vllm/releases/tag/v0.32.0
- https://github.com/vllm-project/vllm/security/advisories/GHSA-x567-49g5-p4cf
Get alerted when CVE-2026-115918 or the next vulnerability affects your stack