What’s Vulnerable › Vulnerabilities
CVE-2026-115930: MongoDB Shell (mongosh) bundled with Node.js trusts certificates issued by recoverable eMudhra intermediate CAs
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-26 · updated 2026-10-26
- Weakness: CWE-295
Description
The MongoDB Shell (mongosh) relies on Node.js as a third-party runtime that carries its own TLS root certificate store. This certificate store has the recoverable eMudhra intermediate CA certificates. This issue impacts MongoDB Shell (mongosh) versions prior to 2.14.0 and can be resolved by updating to mongosh 2.14.0 which bundles Node.js 24.22.1 or later. If mongosh is installed through npm, it uses the Node.js runtime installed on the host; update that runtime separately.
Affected products
- MongoDB Inc mongosh: before 2.14.0 — fixed in 2.14.0
How to fix
Upgrade to a fixed version: MongoDB Inc mongosh 2.14.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-115930 or the next vulnerability affects your stack