What’s Vulnerable › Vulnerabilities
CVE-2026-116011: Crow before 1.3.4 Denial of Service via Deeply Nested JSON in crow::json::load()
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-24 · updated 2026-10-26
- Weakness: CWE-674
Description
Crow before 1.3.4 contains an uncontrolled recursion vulnerability in crow::json::load() that allows remote unauthenticated attackers to crash the server by sending deeply nested JSON. Attackers can send a request body with thousands of nested objects to exhaust the worker thread stack, terminating the process and dropping all connections.
Affected products
- Crow: before 1.3.4 — fixed in 1.3.4
How to fix
Upgrade to a fixed version: Crow 1.3.4. Check the vendor advisory for mitigations.
References
- https://github.com/CrowCpp/Crow/blob/v1.3.3/include/crow/json.h#L878
- https://github.com/CrowCpp/Crow/commit/6956b7ca93c5df22f5aaccd670e5aa000c0d882b
- https://github.com/CrowCpp/Crow/releases/tag/v1.3.4
- https://github.com/CrowCpp/Crow/security/advisories/GHSA-7x84-xhp8-6cqj
- https://www.vulncheck.com/advisories/crow-before-1.3.4-denial-of-service-via-deeply-nested-json-in-crow-json-load
Get alerted when CVE-2026-116011 or the next vulnerability affects your stack