What’s Vulnerable › Vulnerabilities
CVE-2026-116013: OpenResty lua-resty-dns before 0.24 Denial of Service via DNS Response Parsing
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-24 · updated 2026-10-29
- Weakness: CWE-130
Description
OpenResty lua-resty-dns before 0.24 contains an improper input validation vulnerability in parse_section() and _decode_name() that fails to check resource record lengths against the received message. Attackers controlling or spoofing a queried nameserver can send truncated record headers or RDATA, raising uncaught Lua exceptions in resolver:query() that abort requests and break name resolution.
Affected products
- openresty lua-resty-dns: before 0.24 — fixed in 0.24
How to fix
Upgrade to a fixed version: openresty lua-resty-dns 0.24. Check the vendor advisory for mitigations.
References
- https://github.com/openresty/lua-resty-dns/blob/v0.23/lib/resty/dns/resolver.lua#L396-L442
- https://github.com/openresty/lua-resty-dns/commit/b68eaecbf7997ac71c08ba56032b1f45438bd758
- https://github.com/openresty/lua-resty-dns/pull/83
- https://github.com/openresty/lua-resty-dns/tree/v0.24
- https://www.vulncheck.com/advisories/openresty-lua-resty-dns-before-0.24-denial-of-service-via-dns-response-parsing
Get alerted when CVE-2026-116013 or the next vulnerability affects your stack