What’s Vulnerable › Vulnerabilities
CVE-2026-116019: Grav 2.0.15 before 2.2.13 Allowlist Bypass via Flex Form Override Directives
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-24 · updated 2026-10-26
- Weakness: CWE-749
Description
Grav 2.0.15 before 2.2.13 contains an allowlist bypass vulnerability that allows page editors to invoke arbitrary public static methods by relocating data-*@ directives with unset-name@ or integer keys. Attackers with page-edit permission can embed crafted fields in Flex form overrides in page frontmatter to call methods like Folder::delete or Utils::download, deleting directories, overwriting files, or reading files outside the page tree.
Affected products
- getgrav grav: from 2.0.15 before 2.2.13 — fixed in 2.2.13
How to fix
Upgrade to a fixed version: getgrav grav 2.2.13. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/blob/2.2.12/system/src/Grav/Common/Data/Blueprint.php
- https://github.com/getgrav/grav/commit/4d9e3935f6b79cc1a157914554ccca6066a16f87
- https://github.com/getgrav/grav/releases/tag/2.2.13
- https://github.com/getgrav/grav/security/advisories/GHSA-47gg-mh38-9rr7
- https://www.vulncheck.com/advisories/grav-2.0.15-before-2.2.13-allowlist-bypass-via-flex-form-override-directives
Get alerted when CVE-2026-116019 or the next vulnerability affects your stack