What’s Vulnerable › Vulnerabilities
CVE-2026-116071: rotki before 1.44.2 Weak Key Derivation for Premium Cloud Backup Encryption
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-29
- Weakness: CWE-916
Description
rotki before 1.44.2 contains a weak key derivation vulnerability that allows attackers to brute-force backups because the premium sync key is a single unsalted SHA-256 of the user password. Attackers who obtain an uploaded backup blob can run GPU-parallel offline password guessing and decrypt the database containing exchange API keys, secrets, wallet addresses and transaction history.
Affected products
- rotki: before 1.44.2 — fixed in 1.44.2
How to fix
Upgrade to a fixed version: rotki 1.44.2. Check the vendor advisory for mitigations.
References
- https://github.com/rotki/rotki
- https://github.com/rotki/rotki/blob/v1.44.1/rotkehlchen/crypto.py#L17-L45
- https://github.com/rotki/rotki/blob/v1.44.1/rotkehlchen/data_handler.py#L263-L294
- https://github.com/rotki/rotki/issues/13393
- https://github.com/rotki/rotki/pull/13401
- https://github.com/rotki/rotki/releases/tag/v1.44.2
- https://www.vulncheck.com/advisories/rotki-before-1.44.2-weak-key-derivation-for-premium-cloud-backup-encryption
Get alerted when CVE-2026-116071 or the next vulnerability affects your stack