What’s Vulnerable › Vulnerabilities
CVE-2026-116140: ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 Policy Bypass via Delegate Invocation Parsing
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-26
- Weakness: CWE-863
Description
ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 incorrectly parses delegate invocations, which can allow an executable blocked in policy.xml to still run. An attacker who gets ImageMagick to process input that triggers a delegate invocation can bypass the administrator-defined policy and execute the blocked program.
Affected products
- ImageMagick: from 7.0.0-0 before 7.1.2-33; before 6.9.13-58 — fixed in 6.9.13-58, 7.1.2-33
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-58, 7.1.2-33. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-528x-2384-jmxp
- https://www.vulncheck.com/advisories/imagemagick-before-6.9.13-58-and-7-x-before-7.1.2-33-policy-bypass-via-delegate-invocation-parsing
Get alerted when CVE-2026-116140 or the next vulnerability affects your stack