What’s Vulnerable › Vulnerabilities
CVE-2026-116141: ImageMagick before 7.1.2-33 Policy Bypass in UHDR Decoder
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-29
- Weakness: CWE-400
Description
ImageMagick before 7.1.2-33 contains a policy bypass vulnerability in the UHDR decoder that allows attackers to evade image width and height limits because extent checks occur after decoding. Attackers can supply crafted UHDR images with oversized dimensions that are fully decoded before policy limits are enforced, causing excessive resource consumption.
Affected products
- ImageMagick: before 7.1.2-33 — fixed in 7.1.2-33
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-33. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-h3qx-937j-245g
- https://www.vulncheck.com/advisories/imagemagick-before-7.1.2-33-policy-bypass-in-uhdr-decoder
Get alerted when CVE-2026-116141 or the next vulnerability affects your stack