What’s Vulnerable › Vulnerabilities
CVE-2026-116142: ImageMagick before 7.1.2-33 Heap Buffer Over-Read via Minimum-Bounding-Box
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-29
- Weakness: CWE-125
Description
ImageMagick before 7.1.2-33 contains a heap buffer over-read vulnerability that allows attackers to read beyond allocated memory when printing a minimum-bounding-box. Attackers can supply a crafted image that triggers the over-read during minimum-bounding-box output, causing crashes or exposing adjacent heap memory.
Affected products
- ImageMagick: before 7.1.2-33 — fixed in 7.1.2-33
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-33. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-5222-mhv9-26rg
- https://www.vulncheck.com/advisories/imagemagick-before-7.1.2-33-heap-buffer-over-read-via-minimum-bounding-box
Get alerted when CVE-2026-116142 or the next vulnerability affects your stack