What’s Vulnerable › Vulnerabilities
CVE-2026-116143: ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 Policy Bypass in PS, PDF and XPS Decoders
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-26
- Weakness: CWE-770
Description
ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 contains a policy bypass in the PS, PDF and XPS decoders that allows the security policy's list length limit on scene selection to be circumvented. Attackers supplying a specific argument can cause ImageMagick to process more scenes than permitted, potentially exhausting resources.
Affected products
- ImageMagick: from 7.0.0-0 before 7.1.2-33 — fixed in 7.1.2-33
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-33. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-fp46-842c-2v83
- https://www.vulncheck.com/advisories/imagemagick-before-6.9.13-58-and-7-x-before-7.1.2-33-policy-bypass-in-ps-pdf-and-xps-decoders
Get alerted when CVE-2026-116143 or the next vulnerability affects your stack