What’s Vulnerable › Vulnerabilities
CVE-2026-116145: ImageMagick before 6.9.13-58 and 7.x before 7.1.2-32 Security Policy Bypass via Incomplete Fix
- Severity: low (CVSS 3.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-29
- Weakness: CWE-693
Description
ImageMagick before 6.9.13-58 and 7.x before 7.1.2-32 contains a security policy bypass caused by an incomplete fix for the policy bypass reported in GHSA-jjp4-3fwf-393j. An attacker able to supply input to ImageMagick can evade configured security policy restrictions, allowing operations the policy was intended to block.
Affected products
- ImageMagick: from 7.0.0-0 before 7.1.2-32 — fixed in 7.1.2-32
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-32. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-4wfv-467j-fqh9
- https://www.vulncheck.com/advisories/imagemagick-before-6.9.13-58-and-7-x-before-7.1.2-32-security-policy-bypass-via-incomplete-fix
Get alerted when CVE-2026-116145 or the next vulnerability affects your stack