What’s Vulnerable › Vulnerabilities
CVE-2026-116148: ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 Code Injection via MVG Encoder Drawing Options
- Severity: low (CVSS 3.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-26
- Weakness: CWE-79
Description
ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 contains an injection vulnerability in the MVG encoder, which does not properly neutralize user-specified drawing options before writing them into generated MVG output. Attackers who can supply drawing options can inject arbitrary MVG drawing commands into the resulting MVG file.
Affected products
- ImageMagick: from 7.0.0-0 before 7.1.2-33; before 6.9.13-58 — fixed in 6.9.13-58, 7.1.2-33
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-58, 7.1.2-33. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-qq8x-fq3x-43h4
- https://www.vulncheck.com/advisories/imagemagick-before-6.9.13-58-and-7-x-before-7.1.2-33-code-injection-via-mvg-encoder-drawing-options
Get alerted when CVE-2026-116148 or the next vulnerability affects your stack