What’s Vulnerable › Vulnerabilities
CVE-2026-116150: ImageMagick before 7.1.2-33 Memory Leak in FPX Encoder
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-25 · updated 2026-10-26
- Weakness: CWE-401
Description
ImageMagick before 7.1.2-33 contains a memory leak vulnerability in the FPX encoder that allows attackers to exhaust memory by supplying a crafted image. Attackers can submit crafted images for FPX encoding to leak memory repeatedly, causing resource exhaustion and denial of service.
Affected products
- ImageMagick: before 7.1.2-33 — fixed in 7.1.2-33
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-33. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-8w9c-hj38-8pf9
- https://www.vulncheck.com/advisories/imagemagick-before-7.1.2-33-memory-leak-in-fpx-encoder
Get alerted when CVE-2026-116150 or the next vulnerability affects your stack